淘先锋技术网

首页 1 2 3 4 5 6 7


数据结构实验之链表四:有序链表的归并

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

Input

第一行输入M与N的值; 
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

Output

输出合并后的单链表所包含的M+N个有序的整数。

Sample Input

6 5
1 23 26 45 66 99
14 21 28 50 100

Sample Output

1 14 21 23 26 28 45 50 66 99 100

Hint

不得使用数组!

拆开重建,连节点前先比较,找出较小的一个作为节点;

#include <stdio.h>
#include <stdlib.h>

struct node
{
    int data;
    struct node *next;
};

int main()
{
    struct node *head, *tail, *p, *q, *head2;
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    head2 = (struct node *)malloc(sizeof(struct node));
    head2->next = NULL;
    int i, m, n;
    scanf("%d %d",&m,&n);

    tail = head;
    for(i=0; i<m; i++){
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next = NULL;
        tail->next = p;
        tail = p;
    }

    tail = head2;
    for(i=0; i<n; i++){
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next = NULL;
        tail->next = p;
        tail = p;
    }

    p = head->next;
    q = head2->next;
    tail = head;
    while(p&&q){
        if(p->data<q->data){
            tail->next = p;
            tail = p;
            p = p->next;
        }
        else{
            tail->next = q;
            tail = q;
            q = q->next;
        }
    }
    while(p){
        tail->next = p;
        tail = p;
        p = p->next;
    }
    while(q){
        tail->next = q;
        tail = q;
        q = q->next;
    }

    p = head->next;
    while(p->next){
        printf("%d ",p->data);
        p = p->next;
    } printf("%d\n",p->data);

    return 0;
}